Blu-ray Hi-Def Equipment : Two Universal titles no longer working

Two Universal titles no longer working


I've had the same slim-type PS3 since May 2011 and it always worked perfectly until a few weeks ago when I felt like watching Fast Times at Ridgemont High... I put the disc in the console, see the Universal loading logo and then... Nothing happens. The screen just remains black forever. I them tried American Graffiti because I remembered that they came out on the same day and exactly the same thing happens, loading screen then nothing.

I then proceeded to try at least ten of my Unversal titles (such as Carlito's Way; The Frighteners; Cape Fear (1991); Cape Fear (1962); Conan the Barbarian (1982)) and they all worked fine so my conclusion was that both discs must be defective so I tried 'em on my friend's old fat PS3 and they worked just fine. I think it's really strange because I've downloaded the most recent software update and every other disc in my collection works fine.

Any suggestions?

Thanks in advance

BD Collection:

Re: Two Universal titles no longer working

Rip it and burn a movie only DVD, or make an Mkv and play it from a USB drive?

Maybe replace the drive in the PS3. It's not unheard of for drives to become fussy about playing certain kinds of disc.

Re: Two Universal titles no longer working

Try turning off Blu-ray internet access.

Like commentaries?